Senin, 19 Desember 2011

SOAL JARINGAN KOMPUTER



SOAL JARINGAN KOMPUTER

11.   Jelaskan Apa yang dimaksud dengan Computer network.
Computer Network / Jaringan komputer adalah sebuah kumpulan komputer, printer dan peralatan lainnya yang terhubung. Informasi dan data bergerak melalui kabel-kabel sehingga memungkinkan pengguna jaringan komputer dapat saling bertukar dokumen dan data, mencetak pada printer yang sama dan bersama sama menggunakan hardware/software yang terhubung dengan jaringan. Tiap komputer, printer atau periferal yang terhubung dengan jaringan disebut node. Sebuah jaringan komputer dapat memiliki dua, puluhan, ribuan atau bahkan jutaan node.

22.   Sebutkan Topologi jaringan computer, Gambarkan dan berikan keterangan seperlunya.

a.Topologi Bus
b.Topologi Star
c.Topologi Ring
d.Topologi Mesh

e.Topologi Tree
f.Topologi Linier


33.   Apa perbedaan Topologi Logika dan Topologi Fisik pada jaringan computer?
·         Topologi logika jaringan adalah gambaran bagaimana aliran data dalam suatu jaringan
·         Sedangkan topologi fisik adalah bentuk layout pengkabelan yang diimplementasikan pada jaringan. Dapat dikatakan bahwa topologi fisik jaringan adalah konfigurasi semua komputer baik workstation maupun server, peralatan serta kabel dalam suatu jaringan. 
4. Sebutkan keuntungan dan kerugian masing-masing Topologi pada jaringan computer
a.Topologi Bus
Keuntungan :
·         Sangat mudah untuk menghubungkan komputer serta peralatan lainnya pada kabel bus linear.
·         Kabel yang dibutuhkan tidak terlalu banyak.
Kerugian :
·         Jika salah satu sambungan dalam bus linear putus maka seluruh jaringan tidak akan berfungsi.
·         Dibutuhkan terminator pada dua ujung kabel utama.
·         Sulit untuk mengidentifikasi kesalahan jika seluruh jaringan tidak bekerja.
b.Topologi Star
Keuntungan :
·         Mudah dalam instalasi pengkabelan.
·         Tidak ada gangguan dalam jaringan, pada saat memasang dan melepas peralatan.
·         Mudah untuk mendeteksi kesalahan.



Kerugian :
·         Membutuhkan kabel yang cukup panjang.
·         Jika switch atau pusat jaringan rusak maka jaringan tidak akan bekerja.
·         Investasi cukup mahal karena memerlukan peralatan switch/hub/konsentrator.

c.Topologi Ring
Keuntungan :
·         Jika salah satu peralatan rusak, maka tidak akang mengganggu kerja jaringan karena tiap peralatan tidak dihubungkan langsung tetapi melewati bus.

Kerugian :
·         Jika kabel rusak, maka semua peralatan jaringan tidak berfungsi.
·         Sulit dalam pengelolaan.

d.Topologi Tree
Keuntungan :
·         Pengkabelannya point-to-point untuk tiap bagian jaringan.

Kerugian :
·         Jika jalur utama putus maka sistem kerja jaringan tidak akan berfungsi.
·         Sulit dalam konfigurasi dan pengkabelannya.

e.Topologi Mesh :
Keuntungan :
·         Dapat berkomunikasi langsung dengan perangkat tujuan.
·         Data dapat di kirim langsung ke computer tujuan tanpa harus melalui computer lainnya lebih cepat. Satu link di gunakan kusus untuk berkomunikasi dengan computer yang di tuju.
·         Memiliki sifat Robust, yaitu Apabila terjadi gangguan pada koneksi komputer A dengan komputer B karena rusaknya kabel koneksi (links) antara A dan B, maka gangguan tersebut tidak akan mempengaruhi koneksi komputer A dengan komputer lainnya.
·         Mudah dalam proses identifikasi permasalahan pada saat terjadi kerusakan koneksi antar komputer.

Kerugian :
·         Setiap perangkat harus memiliki I/O port. Butuh banyak kabel sehingga butuh banyak biaya.
·         Instalasi dan konfigurasi lebih sulit karena computer yang satu dengan yang lain harus terkoneksi secara langsung.


·       

HIERARKI PROTOKOL, DESAIN LAYER, LAYANAN CONNECTION ORIENTED DAN CONNECTIONLESS


1. Hieraraki Protokol
Hirarki Protokol berfungsi untuk mengurangi kerumitan rancangan, sebagian besar jaringan diorganisasi sebagai tumpukan layer atau level, yang setiap layernya berada di atas layer yang berada dibawahnya. Jumlah, nama, isi, dan fungsi setiap layer dapat  berbeda dari jaringan yang satu dengan jaringan lainnya. Pada semua jaringan, tujuan suatu layer adalah untuk memberikan layanan kepada layer yang berada diatasnya.
Layer n pada sebuah mesin melakukan komunikasi dengan layer n pada mesin lainnya. Hukum dan konvensi yang dipakai dalam pembicaraan ini dikenal secara umum sebagai protokol layer n. Entity dari layer yang bersesuaian pada mesin yang berlainan disebut peer. Peerlah yang berkomunikasi menggunakan protokol. Antara setiap layer yang berdekatan terdapat sebuah interface. Interface menentukan operasi primitive dan layanan layer. Himpunan layer dan protokol disebut arsitektur komunikasi. Daftar protokol yang digunakan oleh suatu sistem , satu protokol satu layer disebut stack protokol.
Sedangkan penjelasan dari protokol sendiri adalah sebuah aturan atau standar yang mengatur atau mengijinkan terjadinya hubungan, komunikasi, dan perpindahan data antara dua atau lebih titik komputer. Protokol dapat diterapkan pada perangkat keras, perangkat lunak atau kombinasi dari keduanya. Pada tingkatan yang terendah, protokol mendefinisikan koneksi perangkat keras. Protocol digunakan untuk menentukan jenis layanan yang akan dilakukan pada internet.

2. Desain Layer
Masalah-masalah pada Desain Layer
Masalah 1 : Munculnya kesalahan (error).
Cara mengatasinya : Menggunakan kode deteksi dan koreksi kesalahan. Pengirim dan penerima harus mempunyai kesepakatan kode mana yang digunakan.
Masalah 2 : Kecepatan pengiriman lebih cepat daripada penerimaan.
Cara mengatasinya : Menggunakan umpan balik (feedback) dari penerima ke pengirim baik secara langsung maupun tidak langsung. Umpan balik berisi keadaan penerima pada saat itu. Umpan balik lainnya berisi pembatasan laju transmisi bagi pengirim.
Masalah 3 : Data yang dikirim terlalu besar.
Cara mengatasinya dengan membuat mekanisme memisahkan, mengirim lalu menggabungkan kembali data tersebut.
Masalah 4 : Data yang dikirim terlalu kecil.
Cara mengatasinya adalah dengan menggabungkan data yang kecil menjadi sebuah data yang besar.

3. Layanan Connection – Oriented & Connectionless
Connection-oriented
Penjelasannya :
  • Layanan ini mirip sistem telepon.
  • Pengguna membuat koneksi.
  • Menggunakan koneksi.
  • Menghentikan koneksi
Connectionless
Penjelasannya :
  • Layanan ini mirip pengiriman pos.
  • Setiap pesan mempunyai alamat dituju.
  • Mempunyai route yg berdiri sendiri.



4. PAN, SAN & GAN
PAN
Personal Area Network (PAN)
  • Network yang menghubungkan berbagai perangkat yang berada dekat pada seorang pengguna komputer.
  • Jangkauannya 6-9 meter.
  • Ex. Jaringan yang menghubungkan sebuah komputerdengan berbagai pendukungnya, seperti printer, mesin fax, telepon, PDA, scanner, dsb
SAN
Storage Area network (SAN)
Storage Area Network (SAN) adalah sebuah jaringan berkecepatan sangat tinggi yang khusus, terdiri dari server dan penyimpanan (storage). Terpisah dan berbeda dengan LAN/WAN perusahaan. Tujuan utama SAN adalah menangani traffik data dalam jumlah besar antar server dan peralatan penyimpanan(Gigabits/sec), tanpa mengurangi bandwidth yang ada di LAN/WAN. Biasanya tersambung melalui fibber Channel, sebuah tekhnologi komunikasi data yang berkecepatan sangat tinggi menjadikan SAN sebuah jaringan dedicated yang platform-independent yang beroprasi dibelakang server.
GAN
  • Istilah untuk network yang akan menghubungkan berbagai wireless network, misalnya WLAN (WiFi dengan hotspotnya), cakupan area sebuah satelit, dsb.
  • Jangkauannya seperti MAN, yaitu melingkupi sebuah kota.
  • Ex. IEEE 802.20, yaitu Mobile Broadband Wireless Access (MBWA), a.k.a Mobile-Fi.

DNS,IPv4 dan IPv6


DNS


DNS adalah sebuah sistem yang menyimpan informasi tentang nama host maupun nama domain dalam bentuk basis data tersebar (distributed database) di dalam jaringan komputer, misalkan: Internet.
Atau dengan kata lain DNS adalah server yang digunakan untuk mengetahui IP Address suatu host lewat host name-nya. Dalam dunia internet, komputer berkomunikasi satu sama lain dengan mengenali IP Address-nya.
DNS menyediakan alamat IP untuk setiap nama host dan mendata setiap server transmisi surat (mail exchange server) yang menerima surat elektronik (email) untuk setiap domain.
DNS (Domain Name Server) ini melakukan encode atau menerjemahkan dari domain google.com ke dalam bentuk deretan angka unik yaitu berupa IP.
misal google.com IP nya adalah 208.67.219.231. Jadi bila kita masukan 208.67.219.231 pada browser maka juga akan membuka domain google.com tersebut.
Penggunaan DNS sangat penting artinya dalam dunia Internet, karena dengan menggunakan DNS yang tepat, akan memberikan pengaruh yang signifikan terhadap kecepatan browser ketika berselancar di Internet.
DNS ditemukan pada tahun 1983 oleh Paul Mockapetris; spesifikasi asli muncul di RFC 882 dan 883. Tahun 1987, penerbitan RFC 1034 dan RFC 1035 membuat update terhadap spesifikasi DNS. Hal ini membuat RFC 882 dan RFC 883 tidak berlaku lagi. Beberapa RFC terkini telah memproposikan beberapa tambahan dari protokol inti DNS.
Fungsi DNS
  • Kerangka Peraturan pengiriman secara kontroversi menggunakan keuntungan jenis rekod DNS, dikenal sebagai rekod TXT.
  • Menyediakan keluwesan untuk kegagalan computer. Beberapa server DNS memberikan perlindungan untuk setiap domain. Tepatnya,Tiga belas server akar (root server)digunakan oleh seluruh dunia.
Keunggulan DNS
  • DNS mudah untuk di implementasikan di protocol TCP/IP
  • DNS server mudah untuk di konfigurasikan(Bagi admin)
  • User tidak lagi di repotkan untuk mengingat IP address
Kekurangan DNS
  • DNS tidak mudah untuk di implementasikan
  • Tidak konsisten
  • Tidak bias membuat banyak nama domain.