DNS ( DOMAIN NAME SERVER )
DNS adalah
sebuah sistem yang menyimpan informasi tentang nama host maupun nama domain
dalam bentuk basis data tersebar (distributed database) di dalam jaringan
komputer, misalkan: Internet.
Atau dengan kata lain DNS adalah
server yang digunakan untuk mengetahui IP Address suatu host lewat host
name-nya. Dalam dunia internet, komputer berkomunikasi satu sama lain dengan
mengenali IP Address-nya.
DNS menyediakan alamat IP untuk
setiap nama host dan mendata setiap server transmisi surat (mail exchange
server) yang menerima surat elektronik (email) untuk setiap domain. DNS (Domain
Name Server) ini melakukan encode atau menerjemahkan dari domain google.com ke
dalam bentuk deretan angka unik yaitu berupa IP. misal google.com IP nya adalah
208.67.219.231. Jadi bila kita masukan 208.67.219.231 pada browser maka juga
akan membuka domain google.com tersebut.
Penggunaan DNS sangat penting
artinya dalam dunia Internet, karena dengan menggunakan DNS yang tepat, akan
memberikan pengaruh yang signifikan terhadap kecepatan browser ketika
berselancar di Internet.
DNS ditemukan pada tahun 1983 oleh
Paul Mockapetris, spesifikasi asli muncul di RFC 882
dan 883. Tahun 1987, penerbitan RFC 1034 dan RFC 1035 membuat update terhadap
spesifikasi DNS. Hal ini membuat RFC 882 dan RFC 883 tidak berlaku lagi.
Beberapa RFC terkini telah memproposikan beberapa tambahan dari protokol inti
DNS.
v
Fungsi DNS
a. Kerangka
Peraturan pengiriman secara kontroversi menggunakan keuntungan jenis rekod DNS,
dikenal sebagai rekod TXT.
b. Menyediakan
keluwesan untuk kegagalan computer. Beberapa server DNS memberikan perlindungan
untuk setiap domain. Tepatnya,13 root server digunakan oleh seluruh dunia.
v
Keunggulan
DNS
a. DNS mudah
untuk di implementasikan di protocol TCP/IP.
b. DNS server
mudah untuk di konfigurasikan(Bagi admin).
c. User tidak
lagi di repotkan untuk mengingat IP address.
v
Kekurangan
DNS
a. DNS tidak
mudah untuk di implementasikan.
b. Tidak konsisten.
c. Tidak bias
membuat banyak nama domain.
v
Query DNS
Mekanisme
Query DNS :
a. Query DNS sama seperti menelusuri alamat pos biasa
b. Untuk menelusuri alamati, alamat dibaca dari belakang.
Contoh : Query ke
“www.paume.itb.ac.id” dilakukan dengan urutan
.id
.ac.id
.itb.ac.id
.paume.itb.ac.id
www.paume.itb.ac.id =
167.205.21.82
Ada proses cache untuk mempercepat
v
Klasifikasi
Nama Domain
•
gTLD (generic Top Level Domain)
Domain yang populer: .com, .net, .org, .gov, .mil, .edu, .int
Sudah ditambah dengan domain-domain lain .aero, .biz, .coop, .info, .museum,
.name, .pro
http://www.iana.org/gtld/gtld.htm
•
ccTLD (country code Top Level Domain)
.ID, .JP, .SG, .US, dll.
Masing-masing dikelola oleh seorang administrator
yang ditunjuk oleh IANA
TCP/IP
A. Pengertian IP dan fungsi
Internet Protokol adalah sistem pengalamatan peralatan berbentuk angka
yang memungkinkan identifikasi satu peralatan dari peralatan lain dalam satu
jaringan terbuka yang sangat besar seperti Internet, agar data yang dikirimkan
dapat sampai ke tujuan yang tepat (Onno W. Purbo ).
Fungsi Internet Protokol adalah menyampaikan datagram dari satu komputer ke komputer lain tanpa
tergantung pada media komputasi yang digunakan ( J. Postel ).
IP address merupakan alamat yang
diberikan pada jaringan komputer dan peralatan jaringan yang menggunakan
protokol TCP/IP. IP address terdiri atas 32 bit angka biner yang dapat
dituliskan sebagai empat kelompok angka desimal yang dipisahkan oleh tanda
titik seperti 192.168.0.1.
IP address terdiri atas dua bagian
yaitu network ID dan host ID, dimana network ID menentukan alamat jaringan
komputer, sedangkan host ID menentukan alamat host (komputer, router, switch).
Oleh sebab itu IP address
memberikan alamat lengkap suatu host beserta alamat jaringan di mana host itu
berada.
Contoh:
NETWORK
ID
|
HOST
ID
|
||
192
|
168
|
0
|
1
|
B. Penggolongan Alamat IP
IP address
dibagi dalam tiga kelas, diantaranya :
1. IP address
kelas A
IP address kelas A diberikan untuk
jaringan dengan jumlah host yang sangat besar. Range IP 1.xxx.xxx.xxx. –
126.xxx.xxx.xxx, terdapat 16.777.214 (16 juta) IP address pada tiap kelas A. IP
address kelas A diberikan untuk jaringan dengan jumlah host yang sangat besar. Pada IP address kelas A, network ID ialah 8
bit pertama, sedangkan host ID ialah 24 bit berikutnya. Dengan demikian, cara
membaca IP address kelas A, misalnya 113.46.5.6 ialah:
Network
ID = 113
Host ID
= 46.5.6
Sehingga
IP address diatas berarti host nomor 46.5.6 pada network nomor 113.
2. IP address
kelas B
IP address kelas B biasanya
dialokasikan untuk jaringan berukuran sedang dan besar.
Pada IP address kelas B, network
ID ialah 16 bit pertama, sedangkan host ID ialah 16 bit berikutnya. Dengan
demikian, cara membaca IP address kelas B, misalnya 132.92.121.1
Network ID = 132.92
Host ID = 121.1
Sehingga IP address di atas
berarti host nomor 121.1 pada network nomor 132.92. dengan panjang host ID 16
bit, network dengan IP address kelas B dapat menampung sekitar 65000 host.
Range IP 128.0.xxx.xxx – 191.155.xxx.xx
3. IP adress
kelas C
IP address kelas C awalnya
digunakan untuk jaringan berukuran kecil (LAN). Host ID ialah 8 bit terakhir.
Dengan konfigurasi ini, bisa dibentuk sekitar 2 juta network dengan
masing-masing network memiliki 256 IP address. Range IP 192.0.0.xxx –
223.255.255.x.
Pengalokasian IP address pada
dasarnya ialah proses memilih network Id dan host ID yang tepat untuk suatu
jaringan. Tepat atau tidaknya konfigurasi ini tergantung dari tujuan yang
hendak dicapai, yaitu mengalokasikan IP address seefisien mungkin.
IPv4
Penulisan
Alamat IPv4
Panjang alamat IPv4 sebesar 32
bit. Alamat IPv4 pada dasarnya terdiri dari dua bagian utama, yaitu identitas
jaringan (network ID) dan identitas computer (host ID). Network ID menyatakan
identitas dari jaringan di mana computer tersebut berada, sementara host ID
menyatakan identitas dari computer itu sendiri.
Pembagian kelas IPv4 :
Kelas A = 00000000 s/d 01111111
= 0
s/d 127
Kelas B = 10000000 s/d
10111111 = 128
s/d 191
Kelas C = 11000000 s/d
11011111 = 192
s/d 223
Kelas D = 11100000 s/d
11101111 = 224
s/d 239
Kelas E = 11110000 s/d 11111111 =
240 s/d 255
Contoh alamat IPv4
202.149.240.66
dengan menggunakan contoh ini, jika administrator men-setup jaringan dengan
semua computer yang memiliki bagian nilai yang sama. 202.149.240.xxx angka yang
bergaris bawah merupakan network ID-nya, sedangkan xxx adalah host ID-nya.
Kelas pada IPv4 mewakili sebuah grup alamat yang dapat dikenali software
sebagai suatu jaringan fisik. Untuk mengetahui suatu alamat IPv4 itu termasuk
kelas apa, kita harus merubah alamat IPv4 tersebut ke dalam nilai biner,
contoh:
10.149.240.66
00001010.10010101.11110000.10000010
dengan memperhatikan 3 nilai biner
pertama kita bisa mengatakan alamat IPv4 di atas adalah kelas A
IPv6
Penulisan
Alamat IPv6
Yang menarik dari IPv6 adalah penjang alamat sebesar
128 bit. Notasi alamat IPv6 ditulis dalam hexadesimal yang dipisahkan dengan
karakter ”:”. Contohnya sebagai berikut:
• 3ffe:0501:008:1234:0260:97ff:fe40:efab
•
ff02:0000:0000:0000:0000:0000:0000:0001
Angka nol didepan dapat
diabaikan sehingga penulisan menjadi:
•
3ffe:501:8:1234:260:97ff:fe40:efab
• fe02:0:0:0:0:0:0:1
Angka nol yang berurutan dapat digantikan dengan karakter ”::”, sehingga
penulisan menjadi:
• fe02::1
Alamat IPv6 yang mempunyai panjang 128 bit dalam hexadesimal tentunya
sulit dihafalkan karena itu alamat numerik jarang digunakan, lebih mudah
menggunakan hostname, untuk itu DNS memegang peranan penting.
Alamat IPv6 sendiri terbagi atas beberapa macam, berdasarkan RFC 3513 :
• Unspecified dengan
notasi ::/128
• Loopback dengan notasi
::1/128
• Multicast dengan
notasi ff00::/8
• Link local unicast
dengan notasi FE80::/8
• Site local unicast
dengan notasi FEC0::/8
• Global unicast
Alamat yang akan digunakan untuk berkomunikasi dengan internet adalah
alamat global unicast. Pembagian alokasi alamat global berdasarkan registrar
(RFC 2928) adalah:
• IANA 2001:000::/29
sampai 2001:01F8::/29
• APNIC 2001:200::/29
sampai 2001:03F8::/29
• ARIN 2001:400::/29
sampai 2001:05F8::/29
• RIPE NCC 2001:600::/29
sampai 2001:06F8::/29
Mekanisme Automatic Tunneling berfungsi melewatkan
paket IPv6 melalui jaringan IPv4 yang telah ada, tanpa merubah infrastruktur jaringan
IPv4. Mekanisme Automatic Tunneling
mempunyai prinsip kerja mengenkapsulasi paket IPv6 dengan header IPv4, kemudian
paket tersebut langsung dikirimkan ke jaringan IPv4.
Fungsi dari enkapsulasi paket IPv6 dengan header
IPv4 adalah agar paket dapat diroutingkan oleh router IPv4. Namun dengan
penambahan header IPv4 ini tentunya paket akan bertambah besar sesuai panjang
header IPv4 yaitu 20 byte.Pertambahan panjang paket ini akan berakibat
bertambah pula waktu delay pengiriman paket.
Kesimpulan
:
IPv4 adalah protokol yang sudah sangat tua yang
tidak mampu mendukung kebutuhan akan komunikasi yang aman, routing yang
fleksibel maupun pengaturan lalu lintas data. Alasan-alasan inilah yang
mendorong munculnya IPv6 ( Internet protocol generasi berikut ).
IPv6 yang memiliki kapasitas address raksasa,
mendukung penyusunan address secara terstruktur, yang memungkinkan Internet
terus berkembang dan menyediakan kemampuan routing baru yang tidak terdapat
pada IPv4.
Tidak ada komentar:
Posting Komentar